安装yii有两种方式,使用归档下载和composer命令安装,安装版本Yii2.0,文章中使用composer下载安装yii2.0,这样以后只需执行一条简单的命令就可以实现安装新的扩展或更新yii。

yii2下载过程:

PHP版本要求:>=7.0
composer.phar下载:
php -r " eval('?>' .file_get_contents('https://getcomposer.org/installer'));"
新建composer.bat
C:bin>echo @php "%~dp0composer.phar" %*>composer.bat
切换到国内镜像:
composer config -g repo.packagist composer https://packagist.phpcomposer.com
安装完 Composer,运行下面的命令来安装 Composer Asset 插件: 
php composer.phar global require "fxp/composer-asset-plugin:^1.2.0"
现在选择的应用程序模板之一,开始安装 Yii 2.0。应用程序模板是一个包含 Yii 写的骨架 Web 应用程序包。
安装基本的应用程序模板,运行下面的命令:
php composer.phar create-project yiisoft/yii2-app-basic basic 2.0.16
安装高级的应用程序模板,运行下面的命令:
php composer.phar create-project yiisoft/yii2-app-advanced advanced 2.0.16
请注意,您可能会被提示安装过程中输入你的 GitHub 的用户名和密码。这是正常的。只要输入它们并继续。
updating 之后要等很久......


点赞(1) 打赏

Comment list 共有 0 条评论

暂无评论

微信小程序

微信扫一扫体验

立即
投稿

微信公众账号

微信扫一扫加关注

发表
评论
返回
顶部