本来好好的在homestead下弄弄laravel,突然在phpstudy下玩了哈,SASS_BINARY_SITE=http://npm.taobao.org/mirrors/node-sass yarn 命令一直报错。

终于还是弄好了:npm i node-sass --sass_binary_site=https://npm.taobao.org/mirrors/node-sass/

请参考:http://www.gxlcms.com/JavaScript-255446.html

Administrator@PC-202005152046 MINGW64 /h/phpstudy_pro/WWW/laravel-shop-l (master)

$ npm -v
6.10.3

Administrator@PC-202005152046 MINGW64 /h/phpstudy_pro/WWW/laravel-shop-l (master)
$ npm i node-sass --sass_binary_site=https://npm.taobao.org/mirrors/node-sass/
npm WARN deprecated request@2.88.2: request has been deprecated, see https://github.com/request/request/issues/3142
npm WARN deprecated har-validator@5.1.5: this

> node-sass@5.0.0 install H:\phpstudy_pro\WWW\laravel-shop-l\node_modules\node-sass
> node scripts/install.js

Downloading binary from https://npm.taobao.org/mirrors/node-sass//v5.0.0/win32-x64-72_binding.node
Download complete
Binary saved to H:\phpstudy_pro\WWW\laravel-shop-l\node_modules\node-sass\vendor\win32-x64-72\binding.node
Caching binary to C:\Users\Administrator\AppData\Roaming\npm-cache\node-sass\5.0.0\win32-x64-72_binding.node

> node-sass@5.0.0 postinstall H:\phpstudy_pro\WWW\laravel-shop-l\node_modules\node-sass
> node scripts/build.js

Binary found at H:\phpstudy_pro\WWW\laravel-shop-l\node_modules\node-sass\vendor\win32-x64-72\binding.node
Testing binary
Binary is fine
npm notice created a lockfile as package-lock.json. You should commit this file.
+ node-sass@5.0.0
added 195 packages from 144 contributors in 25.298s

Administrator@PC-202005152046 MINGW64 /h/phpstudy_pro/WWW/laravel-shop-l (master)
$ npm config set sass_binary_site https://npm.taobao.org/mirrors/node-sass/

Administrator@PC-202005152046 MINGW64 /h/phpstudy_pro/WWW/laravel-shop-l (master)
$ composer require laravel/ui:"^2.0"
./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
Nothing to install or update
Generating optimized autoload files
> Illuminate\Foundation\ComposerScripts::postAutoloadDump
> @php artisan package:discover --ansi
Discovered Package: facade/ignition
Discovered Package: fideloper/proxy
Discovered Package: fruitcake/laravel-cors
Discovered Package: laravel/tinker
Discovered Package: laravel/ui
Discovered Package: nesbot/carbon
Discovered Package: nunomaduro/collision
Package manifest generated successfully.
71 packages you are using are looking for funding.
Use the `composer fund` command to find out more!

Administrator@PC-202005152046 MINGW64 /h/phpstudy_pro/WWW/laravel-shop-l (master)
$ php artisan ui vue
Vue scaffolding installed successfully.
Please run "npm install && npm run dev" to compile your fresh scaffolding.

Administrator@PC-202005152046 MINGW64 /h/phpstudy_pro/WWW/laravel-shop-l (master)
$ rm -f resources/js/components/ExampleComponent.vue

Administrator@PC-202005152046 MINGW64 /h/phpstudy_pro/WWW/laravel-shop-l (master)
$ yarn config set registry https://registry.npm.taobao.org
yarn config v1.22.10
success Set "registry" to "https://registry.npm.taobao.org".
Done in 0.21s.

Administrator@PC-202005152046 MINGW64 /h/phpstudy_pro/WWW/laravel-shop-l (master)
$ SASS_BINARY_SITE=http://npm.taobao.org/mirrors/node-sass yarn
yarn install v1.22.10
info No lockfile found.
warning package-lock.json found. Your project contains lock files generated by tools other than Yarn. It is advised not to mix package managers in order to avoid resolution inconsistencies caused by unsynchronized lock files. To clear this warning, remove package-lock.json.
[1/4] Resolving packages...
warning node-sass > request@2.88.2: request has been deprecated, see https://github.com/request/request/issues/3142
warning node-sass > node-gyp > request@2.88.2: request has been deprecated, see https://github.com/request/request/issues/3142
warning node-sass > request > har-validator@5.1.5: this
warning laravel-mix > chokidar@2.1.8: Chokidar 2 will break on node v14+. Upgrade to chokidar 3 with 15x less dependencies.
warning laravel-mix > webpack-dev-server > chokidar@2.1.8: Chokidar 2 will break on node v14+. Upgrade to chokidar 3 with 15x less dependencies.
warning laravel-mix > chokidar > fsevents@1.2.13: fsevents 1 will break on node v14+ and could be using insecure binaries. Upgrade to fsevents 2.
warning laravel-mix > webpack > watchpack > watchpack-chokidar2 > chokidar@2.1.8: Chokidar 2 will break on node v14+. Upgrade to chokidar 3 with 15x less dependencies.
warning laravel-mix > chokidar > braces > snapdragon > source-map-resolve > resolve-url@0.2.1: https://github.com/lydell/resolve-url#deprecated
warning laravel-mix > chokidar > braces > snapdragon > source-map-resolve > urix@0.1.0: Please see https://github.com/lydell/urix#deprecated
warning popper.js@1.16.1: You can find the new Popper v2 at @popperjs/core, this package is dedicated to the legacy v1
warning resolve-url-loader > urix@0.1.0: Please see https://github.com/lydell/urix#deprecated
warning resolve-url-loader > rework > css > urix@0.1.0: Please see https://github.com/lydell/urix#deprecated
[2/4] Fetching packages...
warning file-loader@2.0.0: Invalid bin field for "file-loader".
info fsevents@1.2.13: The platform "win32" is incompatible with this module.
info "fsevents@1.2.13" is an optional dependency and failed compatibility check. Excluding it from installation.
info fsevents@2.1.3: The platform "win32" is incompatible with this module.
info "fsevents@2.1.3" is an optional dependency and failed compatibility check. Excluding it from installation.
[3/4] Linking dependencies...
warning " > sass-loader@8.0.2" has unmet peer dependency "webpack@^4.36.0 || ^5.0.0".
[4/4] Building fresh packages...
success Saved lockfile.
Done in 112.59s.

点赞(0) 打赏

Comment list 共有 0 条评论

暂无评论

微信小程序

微信扫一扫体验

立即
投稿

微信公众账号

微信扫一扫加关注

发表
评论
返回
顶部